mirror of
https://github.com/alyraffauf/nixcfg.git
synced 2024-11-21 15:13:55 -05:00
Aly Raffauf
29bc4af56e
Some checks are pending
git-mirror / gitlab-sync (push) Waiting to run
nix-build / default-build (push) Waiting to run
nix-build / fallarbor-build (push) Waiting to run
nix-build / lavaridge-build (push) Waiting to run
nix-build / mauville-build (push) Waiting to run
nix-build / petalburg-build (push) Waiting to run
nix-build / rustboro-build (push) Waiting to run
nix-build / slateport-build (push) Waiting to run
nix-check / fmt-check (push) Waiting to run
nix-check / eval-check (push) Waiting to run
* initial committ * move plymouth and printing to desktop modules * rename commonModules -> common * rename commonModules -> common * move nix settings base -> common/nix * nix fmt * move baseModules to common/base
29 lines
672 B
Nix
29 lines
672 B
Nix
{
|
|
config,
|
|
lib,
|
|
...
|
|
}: {
|
|
i18n = {
|
|
defaultLocale = lib.mkDefault "en_US.UTF-8";
|
|
|
|
extraLocaleSettings = {
|
|
LC_ADDRESS = config.i18n.defaultLocale;
|
|
LC_IDENTIFICATION = config.i18n.defaultLocale;
|
|
LC_MEASUREMENT = config.i18n.defaultLocale;
|
|
LC_MONETARY = config.i18n.defaultLocale;
|
|
LC_NAME = config.i18n.defaultLocale;
|
|
LC_NUMERIC = config.i18n.defaultLocale;
|
|
LC_PAPER = config.i18n.defaultLocale;
|
|
LC_TELEPHONE = config.i18n.defaultLocale;
|
|
LC_TIME = config.i18n.defaultLocale;
|
|
};
|
|
};
|
|
|
|
services.xserver.xkb = {
|
|
layout = "us";
|
|
variant = "altgr-intl";
|
|
};
|
|
|
|
time.timeZone = "America/New_York";
|
|
}
|