nixcfg/common/samba.nix
Aly Raffauf 29bc4af56e
Some checks are pending
git-mirror / gitlab-sync (push) Waiting to run
nix-build / default-build (push) Waiting to run
nix-build / fallarbor-build (push) Waiting to run
nix-build / lavaridge-build (push) Waiting to run
nix-build / mauville-build (push) Waiting to run
nix-build / petalburg-build (push) Waiting to run
nix-build / rustboro-build (push) Waiting to run
nix-build / slateport-build (push) Waiting to run
nix-check / fmt-check (push) Waiting to run
nix-check / eval-check (push) Waiting to run
flake: reorg common modules as flake outputs (#95)
* initial committ

* move plymouth and printing to desktop modules

* rename commonModules -> common

* rename commonModules -> common

* move nix settings base -> common/nix

* nix fmt

* move baseModules to common/base
2024-08-22 07:46:19 -04:00

37 lines
744 B
Nix

{config, ...}: {
fileSystems = let
fsType = "cifs";
options = [
"gid=100"
"guest"
"nofail"
"uid=${toString config.users.users.aly.uid}"
"x-systemd.after=network.target"
"x-systemd.after=tailscaled.service"
"x-systemd.automount"
"x-systemd.device-timeout=5s"
"x-systemd.idle-timeout=60"
"x-systemd.mount-timeout=5s"
];
in {
"/mnt/Archive" = {
inherit options fsType;
device = "//mauville/Archive";
};
"/mnt/Media" = {
inherit options fsType;
device = "//mauville/Media";
};
};
home-manager.sharedModules = [
{
gtk.gtk3.bookmarks = [
"file:///mnt/Media"
"file:///mnt/Archive"
];
}
];
}