nixcfg/nixosModules/options.nix
Aly Raffauf 130ecad2a4
Some checks failed
nix-build / default-build (push) Has been cancelled
nix-build / fallarbor-build (push) Has been cancelled
nix-build / lavaridge-build (push) Has been cancelled
nix-build / mauville-build (push) Has been cancelled
nix-build / petalburg-build (push) Has been cancelled
nix-build / rustboro-build (push) Has been cancelled
nix-build / slateport-build (push) Has been cancelled
nix-check / fmt-check (push) Has been cancelled
nix-check / eval-check (push) Has been cancelled
Merge branch 'master' into add-river
2024-09-18 13:06:42 -04:00

44 lines
1.4 KiB
Nix

{
config,
lib,
...
}: {
options.ar = {
apps = {
firefox.enable = lib.mkEnableOption "Firefox Web Browser.";
nicotine-plus.enable = lib.mkEnableOption "Nicotine+ Soulseek client.";
podman.enable = lib.mkEnableOption "Podman for OCI container support.";
steam.enable = lib.mkEnableOption "Valve's Steam for video games.";
virt-manager.enable = lib.mkEnableOption "Virtual machine client.";
};
desktop = {
greetd = {
enable = lib.mkEnableOption "Greetd display manager.";
autologin = lib.mkOption {
description = "User to autologin.";
default = null;
type = lib.types.nullOr lib.types.str;
};
session = lib.mkOption {
description = "Default command to execute on login.";
default = lib.getExe config.programs.hyprland.package;
type = lib.types.str;
};
};
gnome.enable = lib.mkEnableOption "GNOME desktop session.";
hyprland.enable = lib.mkEnableOption "Hyprland wayland session.";
river.enable = lib.mkEnableOption "River wayland session.";
steam.enable = lib.mkEnableOption "Steam + Gamescope session.";
sway.enable = lib.mkEnableOption "Sway wayland session.";
};
laptopMode = lib.mkEnableOption "Enable laptop configuration.";
services.flatpak.enable = lib.mkEnableOption "Flatpak support with GUI.";
};
}