nixcfg/pkgs/rofi-bluetooth.nix
Aly Raffauf 3a18be3b9c
Some checks are pending
git-mirror / gitlab-sync (push) Waiting to run
nix-build / adjustor-build (push) Waiting to run
nix-build / clean-install-build (push) Waiting to run
nix-build / hhd-ui-build (push) Waiting to run
nix-build / rofi-bluetooth-build (push) Waiting to run
nix-build / fallarbor-build (push) Waiting to run
nix-build / lavaridge-build (push) Waiting to run
nix-build / mauville-build (push) Waiting to run
nix-build / pacifidlog-build (push) Waiting to run
nix-build / rustboro-build (push) Waiting to run
nix-build / slateport-build (push) Waiting to run
nix-check / fmt-check (push) Waiting to run
nix-check / eval-check (push) Waiting to run
rofi-bluetooth: fix spelling error in repo name
2024-10-24 19:20:50 -04:00

41 lines
929 B
Nix

{
lib,
stdenv,
fetchFromGitHub,
makeWrapper,
bc,
bluez,
}:
stdenv.mkDerivation {
pname = "rofi-bluetooth";
version = "unstable-2024-07-25";
src = fetchFromGitHub {
owner = "alyraffauf";
repo = "rofi-bluetooth";
rev = "50252e4a9aebe4899a6ef2f7bc11d91b7e4aa8ae";
sha256 = "sha256-o0Sr3/888L/2KzZZP/EcXx+8ZUzdHB/I/VIeVuJvJks=";
};
nativeBuildInputs = [makeWrapper];
installPhase = ''
runHook preInstall
install -D --target-directory=$out/bin/ ./rofi-bluetooth
wrapProgram $out/bin/rofi-bluetooth \
--prefix PATH ":" ${lib.makeBinPath [bc bluez]}
runHook postInstall
'';
meta = with lib; {
description = "Rofi-based interface to connect to bluetooth devices and display status info";
homepage = "https://github.com/alyraffauf/rofi-bluetooth";
license = licenses.gpl3Only;
mainProgram = "rofi-bluetooth";
platforms = platforms.linux;
};
}