nixcfg/common/base.nix
Aly Raffauf b3e3fda67e
Some checks are pending
git-mirror / gitlab-sync (push) Waiting to run
nix-build / adjustor-build (push) Waiting to run
nix-build / clean-install-build (push) Waiting to run
nix-build / hhd-ui-build (push) Waiting to run
nix-build / rofi-bluetooth-build (push) Waiting to run
nix-build / fallarbor-build (push) Waiting to run
nix-build / lavaridge-build (push) Waiting to run
nix-build / mauville-build (push) Waiting to run
nix-build / pacifidlog-build (push) Waiting to run
nix-build / rustboro-build (push) Waiting to run
nix-build / slateport-build (push) Waiting to run
nix-check / fmt-check (push) Waiting to run
nix-check / eval-check (push) Waiting to run
hwModules: integrate legion go improvements (#138)
* hwModuled/amd/cpu: switch to zenpower

* hwModules/framework/13/amd-7000: improve format

* hwModules: add common and common-gaming modules

* hwModules/legion/go: killuserProcesses on logout
2024-10-20 17:29:15 -04:00

44 lines
813 B
Nix

{lib, ...}: {
boot.loader.systemd-boot.configurationLimit = lib.mkDefault 10;
environment.variables.FLAKE = lib.mkDefault "github:alyraffauf/nixcfg";
programs = {
dconf.enable = true; # Needed for home-manager
gnupg.agent = {
enable = true;
enableSSHSupport = true;
};
nh.enable = true;
};
networking.networkmanager.enable = true;
security = {
polkit.enable = true;
rtkit.enable = true;
};
services = {
avahi = {
enable = true;
nssmdns4 = true;
openFirewall = true;
publish = {
enable = true;
addresses = true;
userServices = true;
workstation = true;
};
};
openssh = {
enable = true;
openFirewall = true;
settings.PasswordAuthentication = false;
};
};
}