mirror of
https://github.com/alyraffauf/nixcfg.git
synced 2024-11-21 15:53:55 -05:00
Aly Raffauf
21b840938b
Some checks are pending
git-mirror / gitlab-sync (push) Waiting to run
nix-build / adjustor-build (push) Waiting to run
nix-build / clean-install-build (push) Waiting to run
nix-build / hhd-ui-build (push) Waiting to run
nix-build / rofi-bluetooth-build (push) Waiting to run
nix-build / fallarbor-build (push) Waiting to run
nix-build / lavaridge-build (push) Waiting to run
nix-build / mauville-build (push) Waiting to run
nix-build / pacifidlog-build (push) Waiting to run
nix-build / rustboro-build (push) Waiting to run
nix-build / slateport-build (push) Waiting to run
nix-check / fmt-check (push) Waiting to run
nix-check / eval-check (push) Waiting to run
47 lines
1.2 KiB
Nix
47 lines
1.2 KiB
Nix
{self, ...}: {
|
|
nix = {
|
|
gc = {
|
|
automatic = true;
|
|
dates = "daily";
|
|
options = "--delete-older-than 14d";
|
|
persistent = true;
|
|
randomizedDelaySec = "60min";
|
|
};
|
|
|
|
# Run GC when there is less than 100MiB left.
|
|
extraOptions = ''
|
|
min-free = ${toString (100 * 1024 * 1024)}
|
|
max-free = ${toString (1024 * 1024 * 1024)}
|
|
'';
|
|
|
|
optimise.automatic = true;
|
|
|
|
settings = {
|
|
auto-optimise-store = true;
|
|
experimental-features = ["nix-command" "flakes"];
|
|
|
|
substituters = [
|
|
"https://alyraffauf.cachix.org"
|
|
"https://cache.nixos.org/"
|
|
"https://jovian-nixos.cachix.org"
|
|
"https://nix-community.cachix.org"
|
|
"https://nix-gaming.cachix.org"
|
|
];
|
|
|
|
trusted-public-keys = [
|
|
"alyraffauf.cachix.org-1:GQVrRGfjTtkPGS8M6y7Ik0z4zLt77O0N25ynv2gWzDM="
|
|
"jovian-nixos.cachix.org-1:mAWLjAxLNlfxAnozUjOqGj4AxQwCl7MXwOfu7msVlAo="
|
|
"nix-community.cachix.org-1:mB9FSh9qf2dCimDSUo8Zy7bkq5CX+/rkCWyvRCYg3Fs="
|
|
"nix-gaming.cachix.org-1:nbjlureqMbRAxR1gJ/f3hxemL9svXaZF/Ees8vCUUs4="
|
|
];
|
|
|
|
trusted-users = ["aly"];
|
|
};
|
|
};
|
|
|
|
nixpkgs = {
|
|
config.allowUnfree = true; # Allow unfree packages
|
|
overlays = [self.overlays.default];
|
|
};
|
|
}
|