mirror of
https://github.com/alyraffauf/nixcfg.git
synced 2024-11-21 13:53:56 -05:00
Aly Raffauf
75f53fafee
Some checks are pending
git-mirror / gitlab-sync (push) Waiting to run
nix-build / default-build (push) Waiting to run
nix-build / fallarbor-build (push) Waiting to run
nix-build / lavaridge-build (push) Waiting to run
nix-build / mauville-build (push) Waiting to run
nix-build / petalburg-build (push) Waiting to run
nix-build / rustboro-build (push) Waiting to run
nix-build / slateport-build (push) Waiting to run
nix-check / fmt-check (push) Waiting to run
nix-check / eval-check (push) Waiting to run
59 lines
1.6 KiB
Nix
59 lines
1.6 KiB
Nix
{disks ? ["/dev/nvme0n1"], ...}: {
|
|
disko.devices = {
|
|
disk = {
|
|
main = {
|
|
type = "disk";
|
|
device = builtins.elemAt disks 0;
|
|
|
|
content = {
|
|
type = "gpt";
|
|
|
|
partitions = {
|
|
ESP = {
|
|
priority = 1;
|
|
name = "ESP";
|
|
start = "1M";
|
|
end = "1024M";
|
|
type = "EF00";
|
|
|
|
content = {
|
|
type = "filesystem";
|
|
format = "vfat";
|
|
mountpoint = "/boot";
|
|
};
|
|
};
|
|
|
|
root = {
|
|
size = "100%";
|
|
content = {
|
|
type = "btrfs";
|
|
extraArgs = ["-f"]; # Override existing partition
|
|
# Subvolumes must set a mountpoint in order to be mounted,
|
|
# unless their parent is mounted
|
|
subvolumes = {
|
|
# Subvolume name is different from mountpoint
|
|
"/rootfs" = {
|
|
mountpoint = "/";
|
|
};
|
|
# Subvolume name is the same as the mountpoint
|
|
"/home" = {
|
|
mountOptions = ["compress=zstd"];
|
|
mountpoint = "/home";
|
|
};
|
|
# Parent is not mounted so the mountpoint must be set
|
|
"/nix" = {
|
|
mountOptions = ["compress=zstd" "noatime"];
|
|
mountpoint = "/nix";
|
|
};
|
|
};
|
|
|
|
mountpoint = "/partition-root";
|
|
};
|
|
};
|
|
};
|
|
};
|
|
};
|
|
};
|
|
};
|
|
}
|