nixcfg/nixosModules/options.nix
Aly Raffauf d86e4c5be1
Some checks are pending
git-mirror / gitlab-sync (push) Waiting to run
nix-build / adjustor-build (push) Waiting to run
nix-build / clean-install-build (push) Waiting to run
nix-build / hhd-ui-build (push) Waiting to run
nix-build / rofi-bluetooth-build (push) Waiting to run
nix-build / fallarbor-build (push) Waiting to run
nix-build / lavaridge-build (push) Waiting to run
nix-build / mauville-build (push) Waiting to run
nix-build / pacifidlog-build (push) Waiting to run
nix-build / rustboro-build (push) Waiting to run
nix-build / slateport-build (push) Waiting to run
nix-check / fmt-check (push) Waiting to run
nix-check / eval-check (push) Waiting to run
desktop: add kde modules (#143)
* theme: don't set kde qt theme if kde is enabled

* home: add kde option

* nixos: add kde module

* hyprland: set kde theme variables

* desktop: set libadwaita headerbar buttons for kde

* greetd: tuigreet -> regreet
2024-10-25 15:05:48 -04:00

44 lines
1.4 KiB
Nix

{
config,
lib,
...
}: {
options.ar = {
apps = {
firefox.enable = lib.mkEnableOption "Firefox Web Browser.";
nicotine-plus.enable = lib.mkEnableOption "Nicotine+ Soulseek client.";
podman.enable = lib.mkEnableOption "Podman for OCI container support.";
steam.enable = lib.mkEnableOption "Valve's Steam for video games.";
virt-manager.enable = lib.mkEnableOption "Virtual machine client.";
};
desktop = {
greetd = {
enable = lib.mkEnableOption "Greetd display manager.";
autologin = lib.mkOption {
description = "User to autologin.";
default = null;
type = lib.types.nullOr lib.types.str;
};
session = lib.mkOption {
description = "Default command to execute on login.";
default = lib.getExe config.programs.hyprland.package;
type = lib.types.str;
};
};
gnome.enable = lib.mkEnableOption "GNOME desktop session.";
hyprland.enable = lib.mkEnableOption "Hyprland wayland session.";
kde.enable = lib.mkEnableOption "KDE desktop session.";
steam.enable = lib.mkEnableOption "Steam + Gamescope session.";
sway.enable = lib.mkEnableOption "Sway wayland session.";
};
laptopMode = lib.mkEnableOption "Enable laptop configuration.";
services.flatpak.enable = lib.mkEnableOption "Flatpak support with GUI.";
};
}