mirror of
https://github.com/alyraffauf/nixcfg.git
synced 2024-11-21 13:53:56 -05:00
Aly Raffauf
97db653259
Some checks are pending
git-mirror / gitlab-sync (push) Waiting to run
nix-build / adjustor-build (push) Waiting to run
nix-build / clean-install-build (push) Waiting to run
nix-build / hd-ui-build (push) Waiting to run
nix-build / fallarbor-build (push) Waiting to run
nix-build / lavaridge-build (push) Waiting to run
nix-build / mauville-build (push) Waiting to run
nix-build / pacifidlog-build (push) Waiting to run
nix-build / rustboro-build (push) Waiting to run
nix-build / slateport-build (push) Waiting to run
nix-check / fmt-check (push) Waiting to run
nix-check / eval-check (push) Waiting to run
* overlays: init with tablet overlays * flake: add overlays.tablet * overlays.tablet: document * pacifidlog: migrate to overlays.tablet * pacvifidlog: cleanup * overlays: add rofi-bluetooth * flake: output adjustor and hhd-ui * flake: reorg packages and overlays * flake.devShells.default: add nix-update * github: add adjustor and hhd-ui to ci * githuib: test builds * github: undo test change * pkgs: update descriptions * pkgs: reformat
21 lines
658 B
Nix
21 lines
658 B
Nix
# Text input fixes for electron apps.
|
|
final: prev: {
|
|
brave = prev.brave.override {commandLineArgs = "--gtk-version=4 --enable-wayland-ime";};
|
|
|
|
obsidian = prev.obsidian.overrideAttrs (old: {
|
|
installPhase =
|
|
builtins.replaceStrings ["--ozone-platform=wayland"]
|
|
["--ozone-platform=wayland --enable-wayland-ime"]
|
|
old.installPhase;
|
|
});
|
|
|
|
vscodium = prev.vscodium.override {commandLineArgs = "--enable-wayland-ime";};
|
|
|
|
webcord = prev.webcord.overrideAttrs (old: {
|
|
installPhase =
|
|
builtins.replaceStrings ["--ozone-platform-hint=auto"]
|
|
["--ozone-platform-hint=auto --enable-wayland-ime"]
|
|
old.installPhase;
|
|
});
|
|
}
|