mirror of
https://github.com/alyraffauf/nixcfg.git
synced 2024-11-21 19:53:55 -05:00
Aly Raffauf
4817156964
Some checks are pending
git-mirror / gitlab-sync (push) Waiting to run
nix-build / default-build (push) Waiting to run
nix-build / fallarbor-build (push) Waiting to run
nix-build / lavaridge-build (push) Waiting to run
nix-build / mauville-build (push) Waiting to run
nix-build / petalburg-build (push) Waiting to run
nix-build / rustboro-build (push) Waiting to run
nix-build / slateport-build (push) Waiting to run
nix-check / fmt-check (push) Waiting to run
nix-check / eval-check (push) Waiting to run
16 lines
313 B
Nix
16 lines
313 B
Nix
{
|
|
config,
|
|
lib,
|
|
...
|
|
}: {
|
|
config = lib.mkIf config.ar.users.dustin.enable {
|
|
users.users.dustin = {
|
|
description = "Dustin Raffauf";
|
|
extraGroups = config.ar.users.defaultGroups;
|
|
hashedPassword = config.ar.users.dustin.password;
|
|
isNormalUser = true;
|
|
uid = 1001;
|
|
};
|
|
};
|
|
}
|